Friday, March 2, 2012

NetScaler VPX Install and Web Interface

VPX Install


First you will need to download the latest VPX Appilance from http://www.citrix.com (a mycitrix is required)





You will also need to download the Web Interface components



You will need a VM with at least 4GB of RAM to support more than 3 Sites


Once you have imported the machine, Open the console to setup, you will prompt for the following:

IP Address


Subnet


Default Gateway


Once you have configured the IP Address, enter that into a browser. (Java Required)

You will get a login page simply type nsroot and nsroot, username and password


It is highly recommended to change the Default password


Install Citrix License

You will need to find the Interface on the NetScaler with the lowest MAC Address


Under the Network Folder, > Interfaces




Copy the lowest MAC address


Now go back to your mycitrix account and allocate a NetScaler License


Note if you want to use an Express License




Click on NetScaler VPX Express


About half way through the page you should find a link to Get License




It should be right in-between the Appliances and the Builds/Upgrade packages.


Run through the Allocation Wizard and download the new License file.




Expand the System Folder, and then select Licenses



At the Bottom left of the Frame you should see Manage Licenses…



Click Add… Select the license file you just created and Downloaded, Click Select


Click OK


The device will reboot for the license to take affect


Once it has rebooted, log back in




Expand System and Select Settings





Click on Configure modes



Make sure all the options from the above Screen shot are all checked.




Click Yes to the warning


Click Configure basic features



Make sure all the options from the above Screen shot are all checked.



Click Yes to the warning


Select Web Interface folder


Click On Web Interface



Click Install Web Interface



Click the Dropdown arrow to the right of "Browse (Appliance)" and select Local




Select nswi-1.3.tgz, and click Open




Select diablo-latte-freebsd6-amd64-1.6.0_07-b02.tar.bz2, and Click Open




Click Install,


(Note: if default to 25 sites you will have to have at least 4GB of RAM installed for the VPX otherwise this will error out.)





Web Interface Configuration


Login to the NetScaler and Expand the Web Interface Folder




Select Sites




    Click Add.. at the bottom of the Frame




Click Next




Enter the IP address of the Web Interface Server VIP. Check the Box Enable access through mobile receiver, Click Next




Enter in the XenApp servers here, Just the Data Collectors




    Click next, after you have entered all the Data Collectors












    Highlight the Web Interface Site you just created




    Click on the WebInterface.conf… link at the bottom of the Frame




    Remove the # from the beginning of the Line, and add your Domain Name removing everything else… Click Save




    You will receive a warning, Click Yes




    Click the Add Button at the Bottom of the Frame




    Click Next




    Select XenApp Service Site, Click the Dropdown for Virtual Server, and Select the previously Created Server, Note should be listening on port 80, Click Next




    Click the Add, and add all Data Collectors, Click Next




    Click Finish




    Click Exit


Select the PNA Site (XenApp Service Site)




    Click the config.xml… Button at the bottom of the Frame




    Change the <LogonMethod> from Prompt to Pass-Through, Click Save




    Click Yes to the Warning Message



3 comments:

  1. Seems Citrix has removed the JRE tar and JRE packages ;( Any ideas?

    ReplyDelete
  2. I just checked I believe you have to be logged in with your MyCitrix Account. Citrix doesn't actually host the JRE but does link to the FreeBSD Site... You should be able to find both off the following link.

    Thanks
    L

    ReplyDelete
  3. I guess some accounts can't see the components area, at least completely. I tried another account, my partner account, and all was well. Problem I have now is I get this when adding a site:

    "Import SSL certificate failed. Following command execution failed: ./export_cert.sh/nsconfig/ssl/portal.example.com.pem”

    Seems I have an issue with my cert (.pem format).

    ReplyDelete